Aviutlにて59.94fpsの動画読み込みで音ズレ発生と解決



ゆっくりムービーメーカーで動画を編集したファイルを、Aviutlに読み込ませてエンコードすると音ズレが発生していたのがようやく解決しました。


環境


動画ファイル
:NVIDIAの録画ツール、share(旧shadowplay)で撮った動画VFR(59.94Fps)
 HandbrakeでCFRに変換

関連記事:VFR動画を無劣化でCFR動画に変換できるHandbrakeの使い方

なおCFRに変換しただけの無編集の動画なら、Aviutlにドラックアンドドロップで読み込ませても、拡張編集で読み込ませても音ズレは発生しません。



動画編集環境
:ゆっくりムービーメーカー v3.4.8.1
  Aviutl
 L-SMASH_Works_r589



音ズレ原因の推測


音ズレの原因は、動画ファイルが59.94fpsとなっているせいだと推測しました。

ゆっくりムービーメーカーで編集した動画をAviutl用に読み込ませるため、 exoファイルを出力しますがテキストエディタでexoファイルの中身を見ると以下のように記述されています。

[exedit]
width=1920
height=1080
rate=59.94
scale=1
audio_rate=44100
audio_ch=2

aviutlでは、どうもこのrate=59.94の箇所をrate59で解釈している感じがします。

試しにaviutlの拡張編集でexoを読み込ませた後、拡張編集>右クリック>ファイル>オブジェクトファイルのエクスポートでexoを再度出力させて中身を見ると以下のように書き換わっていました。


[exedit]
width=1920
height=1080
rate=59
scale=1
audio_rate=44100
audio_ch=2

で、最初はここをAviutlが解釈できるように以下の値に書き換えればうまく以下と思ったのですが、駄目でした。

[exedit]
width=1920
height=1080
rate=5994
scale=100

audio_rate=44100
audio_ch=2



解決した設定変更

L-SMASH_Worksの設定変更で音ズレが解決しました。

まずL-SMASH_Worksが最新版になっている確認します。

続いて入力プライグインの優先度を上げ、動画ファイル読み込みにL-SMASH_Worksが使われるように変更します。

 ファイル>環境設定>入力プラグインの優先度設定でL-SMASH_Worksを上に。

L-SMASH_Works

exoファイル読み込みの際に、[Fatal]: Failed to find the first video trackとエラーが出力される場合は、以下の設定を試します。

先ほど画面で設定ボタンをクリックし、設定画面を開き、左上の「Livav+L-SMASH」のチェックを外し、Create Index Fileにチェックが入っていることを確認してokを押す。
Livav+L-SMASH

lwinputのダイアログが出たらOKを押し、Aviutlを一度再起動

lwinput

これで動画読み込み時にIndexファイルを自動で作成してくれるようになり、[Fatal]: Failed to find the first video trackのエラーは出ないようになると思います。


その後、エンコードをしたところ音ズレは解決されました。







■関連記事

1 件のコメント :